Ducati Monster Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Going through my recently purchased 2000 M900, the gauges are a bit twitchy, especially the tac. They're still readable, but not as crisp as the ones were on my S2R, which was in much better shape. The part is basically the same between the two I think. I'm still investigating but I think the gauges were replaced as well, since I found some spliced wires leading out of the gauge cluster. Can anyone with a similar year bike tell me if their gauges do the same? Anyone know a fix to tighten up the accuracy?
 

·
Registered
Joined
·
47 Posts
Possible resistor solution for tac

Going through my recently purchased 2000 M900, the gauges are a bit twitchy, especially the tac. They're still readable, but not as crisp as the ones were on my S2R, which was in much better shape. The part is basically the same between the two I think. I'm still investigating but I think the gauges were replaced as well, since I found some spliced wires leading out of the gauge cluster. Can anyone with a similar year bike tell me if their gauges do the same? Anyone know a fix to tighten up the accuracy?
possibly replaced the tac or added a tac. some M's only came out with a spedometer.

My M400 had no tac so i added one from a cagiva 125 Mito. It worked, but was bouncy, so i had added electronic resistors to the sensor wire. The pick up is a lot smmother & accurate now.

I added 2x 10K ohm 1.5w resistors, they cost me 20c a piece. a cheap fix, if it does not solve the issue, then the tac is wasted, and will have to be replaced, i have been pricing, not very cheap at all.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
I pulled the carmax and DMV reports on it, the millage is pretty consistent so I guess it's accurate. I'd still like to figure out what the wiring is.
 

·
Registered
Joined
·
47 Posts
Something on the gauges, i had notices that when i had replaced my coils & spark plugs, my custom tachometer needle stopped bouncing all over the place, it instead read accurately for the first time that i had installed it on the Duc. I had connected the tacho to the CDI, & it use to be a former laid to rest Cagiva tacho.
 
1 - 4 of 4 Posts
Top