Ducati Monster Motorcycle Forum banner

41 - 46 of 46 Posts

·
Registered
Joined
·
6 Posts
[QUOTE = "dontSTOP, príspevok: 2559290, člen: 105857"]
Ak hľadáte na eBay, mali by ste nájsť univerzálne čerpadlá v rozmedzí medzi 20-50 dolárov.
[/ Quote]
walbro tuším 322 na subaru prietok 560lt
 

·
Registered
Joined
·
2 Posts
I am having the same issue with an '07 695 monster.
Changed the F wires for a new pot from CC Works.......Started up first time, no issue.
Been starting it up 1-2 times a week during lockdown...again, on the button.

Now lockdown is being relaxed, went out and tried strating it to go for a ride yesterday, and the original issue is back (turns over, but won't start) can hear the relays click, have 12V where I should have at the connector before the flange......new wiring harness so not suspecting that....MUST be the fuel pump....nothing else left to change......

Can someone please tell me the correct part no for a bosch or for the Ebay pumps as got one before when I was doing the Fwires kit, thought I'd do the pump too, but had to send it back as it did not fit the 695.....too fat....wouldn't slide into the space vacated by the old pump, and obviously wouldn't clip in.

Its ok for people to say I got it off ebay, go look there, but the one I got sent was a pile of crap that didn't fit.....Anyone actually change the PUMP itself not the epoxy/wiring/pot/etc etc that all been done to death now can do it in my sleep lol......bit the replacement PUMP itself.....please, please please before I torch the damn thing.....
 

·
Registered
Joined
·
74 Posts
Have a photo of the pump that wouldn’t fit? I’m pretty sure there’s only one size with the round flange. was the eBay one oval shaped?
 

·
Registered
Joined
·
2 Posts
Have a photo of the pump that wouldn’t fit? I’m pretty sure there’s only one size with the round flange. was the eBay one oval shaped?
Nope, It was definitely marked up as suitable for 695 - just the pump.....not the entire flange assembly. When it arrived it was about 2mm bigger in circumference (i.e. around 39-40 mm and about 10mm shorter than the original ducati pump....so definitely a chinese knock off that 'fits'...lol

Anyway just got the flange off again and put 12v straight across the pump briefly and pump is ok.....did continuity check and lost continuity on the CCW F-Wires kit on the red feed wire (other wires ok) which has only been fitted for 4-6 weeks at most...... Am I the luckiest man on the planet or what? Going to try and get a replacement under warranty (obviously) but concerned that this (uprated part due to original epoxy failure) too can develop the same fault as the original Ducati part but only within about a month of being fitted :( Im running it on normal fuel not flipping ACID!!!!!!
 
41 - 46 of 46 Posts
Top