Ducati Monster Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3,363 Posts
Discussion Starter #1
OK, my bike has been acting a little strange lately. Mainly starting and with the fuel light. I even posted a few threads about the problems but they are starting to happen more often...like everytime I ride.

First, when starting the clocks will light up and I'll hit the button and I'll hear the starter go click, click, click, click before it fires up. Sounds just like when you have a bad battery but it has power. I'll click about 6 times and then fire up. Sometimes I have to turn it off and try again.

Second, the fuel light will come on while riding and flicker. It'll even mimic throttle input. Roll on the gas...light gets brighter. Throttle down...light dims down. Quick rev....light pops on. Happens even after I fill up the tank.

Any chance these problems are related to the computer/electrics. I asked the shop guys if they heard of similar problems with the '03 bikes and they didn't have any feedback. Also, since the problem comes and goes it didn't act up in front of them. Funny, on the way to the shop for the Sunday ride the light was goofing on me. Get to the shop and it was fine. It is happening more and more often though. Any ideas out there? Computer, gauge cluster, battery?

HELP!
 
S

·
Guest
Joined
·
0 Posts
give your wiring a once over. sounds like you've got an intermittent/loose connection somewhere. definately check the connection at the battery's negative terminal.
 

·
Registered
Joined
·
3,363 Posts
Discussion Starter #3
Strati, that is what I was thinking myself. But since one problem was starter related and one was instrument related I didn't know where to look first. What kind of connections are made to the instrument cluster? Is there a main connection I should check. I'll give the batter terminals a look this evening.
 

·
Registered
Joined
·
374 Posts
One to the two relays under the seat next to the battery could be going bad. That would explain the clicking sound you are hearing while starting. The fuel sensor also connects to the relays as well. I would either swap them around (both are the same) and see if the problem moves or just take them out and apply a voltage across the treminals to see if the engage completely. If they click alot and then engage they are going bad.
 

·
Registered
Joined
·
3,363 Posts
Discussion Starter #5
Andrew, that makes some sense. Because basically when I hit the starter it'll click a bunch and then once it connects, if you will, the bike turns over and starts right up. So it isn't like the battery is dead. Once it cranks it cranks hard and starts right up.

Question, do you know if the fuel sensor is on the same relay as the starter? You say to swap them and see if the problem will move. If the relay is bad where will the problem move to? What is connected to the other relay?
 

·
Registered
Joined
·
374 Posts
I am not sure. I know the right relay as you stand on the left side of the bike facing the raised gas tank (battery terminal facing away from you) is the starter relay. There is another relay right next to in on the left. They are the same type and power relays. I think the fuel system may be on the same as the starter, but I am unsure. As for the other one, I don't really know what it does. Try swapping them over and see if your intial problem goes away. If so you know what to do.
 
1 - 6 of 6 Posts
Top