Ducati Monster Motorcycle Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
OK with your recent "upgrade" I can no longer login to my Ti account. The password fetch does not work. The ask my question does not work. It says my account doesn't exist. I did not receive an e-mail as your instructions stated I would. I had to create a new account. Someone please fix my $25 Ti account back to the way it was before.

Ti account: hingedthinker

New account that I don't need: hingedthinker2

thanks

Marshall

[email protected]
 

· Premium Member
Joined
·
8,486 Posts
hingedthinker2 said:
OK with your recent "upgrade" I can no longer login to my Ti account. The password fetch does not work. The ask my question does not work. It says my account doesn't exist. I did not receive an e-mail as your instructions stated I would. I had to create a new account. Someone please fix my $25 Ti account back to the way it was before.

Ti account: hingedthinker

New account that I don't need: hingedthinker2

thanks

Marshall

[email protected]
your post drips with attitude.

i suggest that you contact one of the board mods to have your situation resolved.
 

· Registered
Joined
·
1,223 Posts
hingedthinker2 said:
I paid $25 for this ****!! I use FREE sites that work reliably....this site....a joke.
Calm down. You didn't pay $25 to use this site. You gave them $25 for some stickers, lanyard, some stars next to your name, and helping support the upkeep of the site.
 

· Registered
Joined
·
1,593 Posts
hingedthinker2 said:
I paid $25 for this nuts!! I use FREE sites that work reliably....this site....a joke.
This site is very reliable.

If you visited more often than twice/year, you'd realize that.

Thanks for reviving a funny old thread. [thumbsup]
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top