Ducati Monster Motorcycle Forum banner

1 - 4 of 4 Posts

·
Banned
Joined
·
7,484 Posts
Discussion Starter #1
Per Chris' instructions re posts for tech help:

I've got an '03 620D (fuel injected) with 1000 miles that is a couple of months old and still under warranty. It
 
B

·
Guest
Joined
·
0 Posts
I know my 2002 750 does the same thing. I do not use my kill switch, heard somewhere that it was for emergencies only and shouldn't be used daily. The starter has kept on until I turned the bike off, or it started. Don't know if this is normal, or if it helps.
 

·
Registered
Joined
·
8,800 Posts
This seems to be a software glitch in the new 5.9 ECU (Ignition/Fuel Injection Box). My '02 S4 has done it a couple of times, other folks with '02 and later Monsters seem to have it happen occasionally.

It hasn't amounted to anything more than an annoyance for me, and nobody has reported any trouble from this issue.

Just FYI, when you push the start button, you are 'asking' the ECU to start the bike. It looks at all of the sensors, and decides whether it will start the bike or not. Apparently, it gets confused occasionally. Just 'reboot' with the key as you have been doing.
 

·
Premium Member
Joined
·
147 Posts
Add my S4 to the list. Since my battery swap it tends to fire off first time so it has not happened in a while. When it does stick, only switching it off with the key works. I'm not sure its a glitch. I've been told that under certain conditions, it's programmed to keep turning until it starts.
 
1 - 4 of 4 Posts
Top