Ducati Monster Motorcycle Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
As this is my first post, allow me to introduce myself. My name is Will Ratzlaff, and I'm the guy on the yellow Monster with carbon low-pipes as seen by a black Volvo wagon about 2 weeks ago, and was also seen in A.G. at Jack in the Box a few months back. Why I haven't posted until now, I don't know. But anyways...

The reason for my posting, and I sincerely hope it's appropriate to ask this on here, is I need some serious mechanical help with my Monster. I am a starving Cal Poly student, and can't afford to have it professionally worked on, and all my tools are at my parent's ranch 200 miles away. I know cars well enough that I built and installed a 390 for my dad's '65 Ford, but have never worked on a motorcycle. I am wondering if there's anyone out there that would be willing to donate their knowledge and time (and garage, as I live in an apartment and they won't let me wrench *stupid*) in exchange for knowing you've helped out a fellow person. (and gained a riding buddy?)

If you're interested, I've got a 2000 Ducati Monster 900 S ie. 29,500miles.

The general problems i'm having are:

Tach doesn't work, spedo does.
High idle with choke off, estimated around 3-4K RPM. Changing choke position makes no difference.
Sometimes starts on first try, sometimes acts like there's a dead battery and won't turn over (batt is 4 months old), happens whether or not it is cold, or been ridden a distance.
Runs VERY poorly, cuts out a lot, misses horridly under 4-5K RPM (est), makes it hard to ride.

I've been putting about 1,500 miles a month on it since I bought it in July, and rely heavily on it to get to work, school and the rare chance I actually get to go home to visit family. So any help would be greatly appreciated!
 

·
Registered
Joined
·
6,149 Posts
welcome to the club (i was the black volvo)

it sounds like you may have some electrical gremlins and perhaps just need to adjust the idle?
wish i could help...
 

·
Registered
Joined
·
1,660 Posts
Sorry, no garage and I don't know much either. I do have a few tools here that I'd be happy to lend you if find a place to work on your bike and I'd be happy to lend a hand if I can help. Also, if you need a rear stand for chain adjustment just let me know. I think your model has the dual arm aluminum swing arm, right? I'm the red monster w/ carbon pipes and fenders that you might see around town once in a while (not within the last month... damn accident).

Also, I get a similar starting problem where sometimes it just doesn't wanna turn over and acts like the battery is dead. Try postin your technical problems in the tech section and then if you need any help trying out their solutions I can try and lend you a hand.
 
1 - 3 of 3 Posts
Top