Ducati Monster Motorcycle Forum banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
230 Posts
Discussion Starter #1
Has anyone else had this issue? I installed the tail on my 02 S4 today, and when I went to put the seat back on the thing will not latch! not enough room for it to clear. Any suggestions? I have a Sargent seat...

Thanks and happy holidays!
 

·
Registered
Joined
·
8,800 Posts
You can attach shims to the bosses at the rear of the seat that sit on the frame, and shim with washers under the latch plate or under the latch-post that's attached to the seat.

That will support the seat in a slightly higher position, allow it to latch, and keep it up off of the taillight (or whatever it's stopping on now).
 

·
Registered
Joined
·
99 Posts
Will this be a problem with the standard seat.....?
I have a 02 s4,an just got the shift-tec tailchop kit.....
 

·
Registered
Joined
·
8,800 Posts
Articmonster said:
Will this be a problem with the standard seat.....?
I have a 02 s4,an just got the shift-tec tailchop kit.....
Maybe.... :-\

Tonkoshala has a combination of two aftermarket parts, and sometimes things just don't play well together.
The manufacturers can't possibly try every possible combination.

I've got an S4R seat on my S4, and I had to shim between the seat and the frame to get it to fit properly.
Something changed at Ducati, as there were similar fitment issues with Sargents on the S4R.
 

·
Premium Member
Joined
·
230 Posts
Discussion Starter #6
The stock seat fit a little easier yet there are still come clearance issues. I've place 3 washers on each side under the latch and it is working for now...I don't really trust it as a long term fix the screws didn't have IMO enough lead wy to screw tight. But it's 60 outside and I wanna ride. I'll post more when a better fit comes along. Thanks for all y'all's advice!
 

·
Premium Member
Joined
·
75 Posts
I have the shift tech CF tail and a Sargent seat and I had to add 3 washes under the latch for it to lock. When I had the factory seat on I didn't have a problem.
 

·
Premium Member
Joined
·
230 Posts
Discussion Starter #8
Got it pretty secure now. The 3 washers didn't work. The seat came unlatched every time it got to much pressure on it. Took a closer look at it and the cargo latches were hitting the tail. What I did was removed the cargo latches that are on the seat put the screws back in with some eletrical tap on them cause they still hit the tail a bit. Then I happened to have a plate from my old latch where the stem had fallen off. I added it under the main stem and it works great now. Guess there is no real soild way to do it it's kinda a trial and error kinda thing like with most aftermarket parts...
 

·
Registered
Joined
·
158 Posts
My '04 S4R always had a problem with the seat latching. I played around with it and finally discovered the stock spring used in the latch wasnt strong enough to keep the latch locked (especially during wheelies!). The stock spring is very weak. I solved this problem by replacing the stock spring with one with more tension sourced from Ace hardware. I havent had a problem since this mod.
 

·
Premium Member
Joined
·
413 Posts
i have a shift-tech cf tail chop which i thought was an easy installation. immediately i noticed the seat was just shy of locking. i used one ss washer on each bolt on the latch. it corrected the problem & i've never had a problem since.
 
1 - 10 of 10 Posts
Top