Ducati Monster Motorcycle Forum banner

1 - 2 of 2 Posts

·
Premium Member
Joined
·
142 Posts
Discussion Starter #1
I have a new to me 2005 S2R800. It came w/ a full Arrow system (no udder) and an open air box w/ K&N air filter. The previous owner told me he did not reflash the ECU as it was not needed w/ the Arrows. It ran fine when I got it. I have put approx 500 miles on it.

I changed the plugs this week and they were black and sooty. I went to the local dealer and he found the CO set at 8.0% and the air bleed screws backed out 2 - 2 1/2 turns. He reset the CO to 4.25% and the air bleeds to 1 - 1 1/2 turns. The plugs look okay now but the bike stumbles and stutters at low speed and/or partial throttle. It idles fine and pulls hard.

If anyone out there has the same set up, what CO and air bleed are you running? Did you have to reflash your chip or are you using a Power Commander or similar device?

Thanks
 

·
Registered
Joined
·
18 Posts
I have a new to me 2005 S2R800. It came w/ a full Arrow system (no udder) and an open air box w/ K&N air filter. The previous owner told me he did not reflash the ECU as it was not needed w/ the Arrows. It ran fine when I got it. I have put approx 500 miles on it.

I changed the plugs this week and they were black and sooty. I went to the local dealer and he found the CO set at 8.0% and the air bleed screws backed out 2 - 2 1/2 turns. He reset the CO to 4.25% and the air bleeds to 1 - 1 1/2 turns. The plugs look okay now but the bike stumbles and stutters at low speed and/or partial throttle. It idles fine and pulls hard.

If anyone out there has the same set up, what CO and air bleed are you running? Did you have to reflash your chip or are you using a Power Commander or similar device?

Thanks
I have a 2008 S2R, with slip-ons and open airbox...I have the upgraded ecu (it came with the system)...I've had to have it adjusted to idle a lil' smoother but I couldn't imagine running it without the ecu...The bikes are just too temperamental to "open" up the exhaust system and not adjust the ecu settings...I can see what comp. the system came with...I'm sure they sell it solo...Also, what octane of gas are you running?
 
1 - 2 of 2 Posts
Top