Ducati Monster Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter #1
I have just noticed the oil pressure light on my '02 MS4 is faintly lit. I can only see it at night or when when the sun isn't shining too brightly. It goes out when either the front or back brake is applied. Not enough to slow down, just enough to light the brake light. This is also the case when idling at a stop, so I know it isn't the oil sloshing around. The bike has 2200 miles and was serviced by my dealer at 650 miles with the usual stuff. The oil level is at the top mark when the bike is level and standing up straight. The bike is still under warrranty.

My question is: Should I be concerned and stop riding it 'till I get it to the dealer? Or does it even need to go to the dealer? Thanks in advance, Alan
 

·
Registered
Joined
·
45,105 Posts
did you wash the bike just before this happened? sounds like the connector at the sending unit is damp, causing a ground. unplug the connector overnight so it can dry out. then try it. if all is good, pack the connector with dielectric grease.

when an oil light comes on, the proper thing to do is cease operation untill good oil pressure is confirmed with a mechanical gauge. therefore, i would not recommend riding it. on the other hand, if it were mine i would probably take the chance.
 

·
Registered
Joined
·
129 Posts
Discussion Starter #3
Yes, I did just wash it. I have the connector unplugged now and will follow your instructions. Thanks for the advice, Alan
 

·
Registered
Joined
·
129 Posts
Discussion Starter #4
It worked like a charm. Spank-you very much, Alan
 
1 - 4 of 4 Posts
Top