Ducati Monster Motorcycle Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
So, I just bought an '04 Monster 620ie. It has Termi (Hi-Mount) pipes and the Ducati performance air filter/opened box. I'm having an issue with it stalling when I'm sitting @ lights/stop signs. If I burp the throttle in neutral, it just keeps happily idling along. However, if I'm in gear, and do the same thing, it falls on its face and dies. The oil light comes on and it will not even turn the starter until I put the bike in neutral, turn the key off/on and thumb the starter. This happens both when the bike is cold AND warm. Think I figured out that, it wont start right up with the bike in gear (duh) even if the clutch is engaged. But, even with the bike in neutral, I still have to turn the key off/on. I thought the problem was the idle being set too low (+/-800rpm). After a little digging, I found the recommended idle speed to be 1100-1200rpm.(?) So, I fiddled with the adjuster screw till it was right about there...ish. After a little bit of warming/revving in the garage, I found the problem still happening. Also, without the OH S#!T factor involved, I was disturbed to hear what sounds like a backfire in the airbox:eek:! I've heard of this with a carburator, but not an Fi equipped vehicle. How do I fix? Is it running too rich? I was raised by an ASE multiple Master mechanic, and have reasonable mech. skills, but am NOT above taking my baby to someone who KNOWS how to fix her. Please help a noob! Any input would be GREATLY appritiated. THX!
 
1 - 1 of 1 Posts
Top