Ducati Monster Motorcycle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hey guys,

All of my light went off on my was home. The dash, brake and headlights off. I notice when I hold the high-beam flasher button on the left handle. The dash lights up and the dials move and then I can start the bike up.

What do you think probably happen. I just got it out of the shop Friday and it was running good. I did change the light bulb this morning to a H4 cool blue. Could this have cause the lights to go out?
 

·
Registered
Joined
·
83 Posts
Hey guys,

All of my light went off on my was home. The dash, brake and headlights off. I notice when I hold the high-beam flasher button on the left handle. The dash lights up and the dials move and then I can start the bike up.

What do you think probably happen. I just got it out of the shop Friday and it was running good. I did change the light bulb this morning to a H4 cool blue. Could this have cause the lights to go out?
Well it sounds like a harness might not be pushed together tight.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Fixed!!! Light 15amp fuse blown. Will check the harness to see if this may have cause this to happen.

Thanks...
 

·
Registered
Joined
·
83 Posts
Ok it sounds like the harness isn't the issue. It seems to me that the new light has put u over the 15 amps that fuse can give u. I would replace and ride a bit at night and see if it blows again. With all the lights being on that one 15 amp fuse, that h2 must have pushed it just to much. You can go up to a 20 amp fuse but try another 15 first. Don't go any higher than a 20 amp fuse. Any more and it might not ever pop if there is a problem, well some thing will pop just not the fuse. Hope this helps.
 
1 - 4 of 4 Posts
Top