Ducati Monster Motorcycle Forum banner

1 - 6 of 6 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Read "HI" and blinked...looked at the fans and they are'nt comming on...shut down before she got too hot.

My dealer is 100miles away. Any ideas? :-/
 

·
Registered
Joined
·
8,800 Posts
Rama,

If your S4R is wired like my '02 S4, the fans are controlled directly by the ECU. They come on at about 215 degrees F.

There are 2 thermosensors, one in each coolant elbow attached to each cylinder head on the left side. Confirm that both of those have the connectors plugged in. One thermosensor is for the digital temp gauge, so that one is obviously working. The other one goes to the ECU. Try unplugging and replugging the connectors on those thermosensors, one may not be fully seated.

Also, confirm that the fans are plugged in also.

On my '02 S4, both thermosensors are the same part. Theoretically, I could switch the plugs between the two and it would still operate normally. You may be able to do that, but I don't have the wiring diagram or parts manual for the S4R, so it could be risky.

If you can't find anything obviously wrong, call the dealer and have 'em pick the bike up. It would be covered under warranty.

Or, ride it over to the dealer in the morning when it's still cool. As long as you keep up a decent speed, the fans won't need to come on.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Got it sorted. The fan fuse was'nt bad but was'nt seated right. Works good now. Whew. ::)

Thanks
 

·
Registered
Joined
·
8,800 Posts
Oh yeah...check your fan fuse. :-[
Glad it was something simple. Enjoy!
 

·
Premium Member
Joined
·
1,314 Posts
RRe: New MS4R fan not comming on...

Rama:

What was the ambient temp when you were riding your S4R? I wonder if they run hotter than the standard S4's? They are certainly higher performance.
Regards,
Rideon
 
1 - 6 of 6 Posts
Top