Ducati Monster Motorcycle Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
It is a 2000 model 900. It is what is called the City pack so has side bags and large screen (which I took off as soon as it was delivered). Just need to sort a problem with the brake light always on, and I'll be away!!

I love it.

 

·
Registered
Joined
·
1,836 Posts
congratulations on the new bike! Are the rearsets really as bright blue as they look on my computer?

I had the same problem with my brake light being on. It was the spring for the rear brake pedal. Somehow it had come loose, all I had to do was move it back around so it would hold the pedal off the (sensor) unless it is manually depressed. You might check that and see if you are having the same problem as I did. Good Luck
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #3 ·
Yes, the rearsets really are that bright. The previous owner asked for dark blue. The powder coaters took so long to get them done that he couldn't be bothered getting them to fix it, he just wanted to put them back on and ride! I'll probably take them back to silver.

I'll have a look at that when I get home tonight. Cheers!
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #5 ·
Yeah, that'd be my worry. Hence my thinking that silver was a safer option ;)
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #9 ·
Thanks guys. That is the original colour scheme of the bike.

I found the problem with the brake light. When the PO put the rearsets back on, he forgot to install the rear brakes switch. The thread was powder coated as well, so putting the switch back in was tight. Too tight for the 7/16th spanner I was using because I didn't have an 11mm. Off to the shops today to complete the repair tonight!

Doesn't matter too much anyway, because it has been raining ever since I got it and I've never ridden in the rain before and I'm not overly keen to start just yet!
 
1 - 9 of 9 Posts
Top