Ducati Monster Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi!

Got my Pro-Flo clipons today and they fit "llllllllike a glove" just below the tripleclamp, B-E-A-ytiful!!! (Sorry got carried away with the Jim Carrey-thingy there.)

Thing is, after I've removed all the bolts the handles/grips still won't move. Could I have missed any bolts? I only found ONE on the clutch-side, and TWO on the throttle-side.

Could that stupid idiot (pardon my French), who owned the bike before me, have glued both sides to the handlebar? Or am I overlooking some bolts?

Plz advise!! The sun is out and the temp here in Sweden is nearly 10 degrees Celsius so it's almost ideal Monster-weather ;D ! And I can't go out and play in the sun because my front end is in bits and bolts.
 

·
Registered
Joined
·
8,800 Posts
What model and year of Monster do you have?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
My Monster is a M600 from 1995.

So once solvent is applied there should be no worries? What is the risk that the handles come off in pieces?

/fred
 

·
Registered
Joined
·
9 Posts
Fred,

Are there any pics to be seen of the pro flo's?
Also where did you get them and what was the price,
and have you been riding with the new stuff. Good experiences?
 

·
Registered
Joined
·
426 Posts
There are nubs on the switches sticking into holes in the bars. You probably have to remove the bolts entirely so that you can pull the nubs out.
 
1 - 6 of 6 Posts
Top