Ducati Monster Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hallow,

I have a Ducati Monster 900 2001 model… it's giving me problems now. :-[ One injector is not working that is what my technician is saying. Dose any one experienced this problem??? Is this a CPU problem? How can I fix this?

Please advice !! (CPU model is IAW15M.A8)

Thanks a lot !!!
 

·
Registered
Joined
·
45,105 Posts
Not hard to find if it is the injector or computer. If the injector is getting a signal it is the injector, no signal computer or wire. If your tech can't tell you which it isyou are in the wrong shop. A quick no meter no wiring diagram check would be switch injectors from one cylinder to the other. if the problem changes cylinders it is the injector.
 

·
Registered
Joined
·
6,266 Posts
Or ask him if hes checked for signal at the injector with a noid light.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
howie said:
Not hard to find if it is the injector or computer. If the injector is getting a signal it is the injector, no signal computer or wire. If your tech can't tell you which it isyou are in the wrong shop. A quick no meter no wiring diagram check would be switch injectors from one cylinder to the other. if the problem changes cylinders it is the injector.
Thanks howei, ducman851 !!!

I think he has changed the injector one to another and its seems like a computer problem. Can you please pull some purchase links for a computer???

Thanks a lot !
 

·
Registered
Joined
·
45,105 Posts
The computer would be pretty much a dealer item unless you can find one used. You might want to post in "parts wanted" in the classifieds on this board.
 

·
Registered
Joined
·
6,266 Posts
Another thing might be to check continuity from the injector plugs back to the ECU to confirm that there are no opens or broken wires. It would suck to replace an ECU for a broken wire.
 

·
Registered
Joined
·
1 Posts
i have same problem with Monster 620 i.e 2003
i check wire and this is ok

I do not know what to do

maybe ecu is problem?
 
1 - 9 of 9 Posts
Top