Ducati Monster Motorcycle Forum banner

1 - 4 of 4 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Well guys,

I just picked up my bike from the dealer this past weekend after having it in for the oil light coming on. I posted baout this a while ago, and it turned out that a small oring had moved slightly out of place when re-installing the clutch side engine case. Anyway, it's fixed now and I didn't have to freeze doing it either. ::) However, riding it home from the dealer in about 32F weather I noticed it was super responsive and attributed it to the cold air. (The bikes got a jet kit, open air box, and foam filter) I was a little surprisd when I got on it and made a fast acceleration run and heard a noise which I thought sounded like an internal engine knock. At the next light I payed extra attention to the idle, which sounded fine, revved it a little which also sounded fine... So I hold off on the hard accel runs until I get home when I can listen to it without a helmet. So I got home and proceeded to run it through the revs in nuetral and noticed that it was actually popping/sputtering or backfiring through the exhaust. THe engine sounded fine from what i could hear through the clutch and termi exhaust :p From my years of moto-x experience and tuning carbs on my race bikes I'm thinking it's the jetting being a little lean. I'll have to do a plug check to really tell, but do most of you have to readjust jetting for the cold weather?
 

·
Registered
Joined
·
100 Posts
Re: M900 breaking up/popping under load... Jetting

My '97 m900 ran like a dog when the temp' got low in the winter, even with the oil circuit round the float bowls it had no effect until the engine was really warmed up. Coming up to junctions you had to constantly blip the throttle like a boy racer to stop it stalling.
I later had a Buell M2 for a while and it had the same carb' icing disease in the winter, but the Harley shop had this petrol additive stuff called 'Idle boost' which allowed the bike to behave almost perfectly. It would start OK, cough occassionaly but it would idle OK. Maybe you could try some of that stuff, the engines are different but the problem is essentially the same.
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Re: M900 breaking up/popping under load... Jetting

Actually, my idle seems fine. Normal crusing and idle was just as before, but under hard accel it popped up in the revs.
 
1 - 4 of 4 Posts
Top