Ducati Monster Motorcycle Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ever since I fitted my bike with the Termignoni cans, (+ECU and airfilter) it feels as if the bike have started to misfire/backfire quite a bit. Is this normal? Is it bad for the engine in any way? Does the ECU work flawlessly or is additional mapping usually necessary?
 

·
Registered
Joined
·
48 Posts
My 696 was doing this as well especially when rolling off the throttle around 4000 RPM. The shop was able to fix it. Without having the shop dig through my work orders, they said they would have adjusted the TPS or trim. Doesn't backfire anymore.
 

·
Registered
Joined
·
138 Posts
I'm experiencing the same thing. I'm not worried about backfire (attributed to unburned exhaust gasses igniting in the muffler's) so much as the rough idle and engine performance below 3,500 RPM. It sounds to me like the engine is not sparking constantly... Power and MPG's seem fine, but it just sounds rough and isn't as smooth around town. I'm sure some will say, "That's just how it is, enjoy the extra power and sound." But, I want the engine to run as smooth as possible as that's sure to add longevity as well as more riding pleasure.

Let's hope someone chimes in with some concrete suggestions/experience here. I just started another Thread on the same topic.
 

·
Registered
Joined
·
115 Posts
Same problem with my 2009 696 with Termi's....will take to the shop. Also, smells of gas a lot. Thanks for the advice.
 
1 - 7 of 7 Posts
Top