Ducati Monster Motorcycle Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
coupla times yesterday when i tried to start my 96 m900, the panel wouldn't light up and wouldn't kick. i must have a short somewhere close to the switch. if i can get the switch out, i can resolder the connections. can anybody send me a pdf of how to pull the switch? i took the two hex screws out and couldn't see how to release the switch proper so i reinstalled to wait for info.....thanks...
 

·
Registered
Joined
·
8,324 Posts
I doubt it is the switch. It is more likely a glitchy main relay. It is located under the seat next to the turn signal flasher and fuse panel.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
ducpainter said:
I doubt it is the switch. It is more likely a glitchy main relay. It is located under the seat next to the turn signal flasher and fuse panel.
gonna take it to the shop for the gear shift issue in the morning and will have them check out the relay....just downloaded the workshop manual from the website and will start studying....thanks for the getback!! this is my second moto, the first was a $300 79 honda cx500 i rebuilt and rode for a year....a friend sold me this duc and its awesome...i wanna know how to fix some if not all things...or at least diagnose the problems and cut shop costs....thanks again!!
 

·
Registered
Joined
·
8,324 Posts
Good luck with it.
 

·
Premium Member
Joined
·
1,386 Posts
+1 on the relay.
 
1 - 6 of 6 Posts
Top