Ducati Monster Motorcycle Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
2001 Monster 750. A week or so ago my friend tried to ride it and couldn't get it started. I figured he flooded it, because it started fine the next go round. Then it wouldn't start again.

Checked plugs, no spark.
Fuel pump primes.
Starter motor runs.
Just no spark.
Don't seem to be getting a pulsing charge from the wires that go into the coil.

Apparently others have had this problem:
http://www.ducatimonster.org/forums/tech/182307-2001-m900-wont-start-no-spark-either-cylinder.html

http://www.ducatimonster.org/forums/tech/196615-02-620ie-wont-start-starter-switch-times-out.html

But nobody has posted a definitive solution. There is talk of unplugging and replugging a white plug above the throttle linkage but I can't locate anything like that.

Could someone with a wiring diagram tell me what wires coming out of the ECU run are supposed to fire the coils?

Any other suggestions?

THANKS!
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #2 ·
bike is fixed! I traced it down to the crankshaft position sensor and checked the gap, it was off. Squared it away and it fired right up!
 

·
Premium Member
Joined
·
3 Posts
1994 M900 Also "No spark" getting to coils. is it stator? regulator? relay? help

bike is fixed! I traced it down to the crankshaft position sensor and checked the gap, it was off. Squared it away and it fired right up!
1994 M900 no spark to coils..
I WANNA RIDE...HELP! : / I'm finally working on my bike myself and putting time into it and it started but i turned it off to drain and rinse and refill tank from winter, i fixed my headlight, made and hardwired my own led panel running and brake light from the online tutorial... i got a new battery and plugs and now i can't get it started. i used an inline tester and no spark..then i used a meter to test impedence and it seems all good from the coils to the plugs so there must not be spark getting to the coils...the only thing i know before the coils is the regulator(cdi box) , the stator, and a relay perhaps? i don't know if i blew something out with the new brakelight i wired or most likely being an idiot and using the "start engine" mode on a car battery charger to get more power to try and get my bike started which i have done in years past but i was told that it's way too many amps for my bike and i probably blew something from that. Does ANYone know what would have gone first? or how to test the stator or regulator to see which is bad? i'd like to buy the parts and fix it myself. i figure i could buy and install both parts for the same price as taking it somewhere to diagnose it and put in one. anyone? any ideas? suggestions? I WANNA RIDE!! HELP! : /
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #4 ·
Check crankshaft position sensor gap.

1994 M900 no spark to coils..
I WANNA RIDE...HELP! : / I'm finally working on my bike myself and putting time into it and it started but i turned it off to drain and rinse and refill tank from winter, i fixed my headlight, made and hardwired my own led panel running and brake light from the online tutorial... i got a new battery and plugs and now i can't get it started. i used an inline tester and no spark..then i used a meter to test impedence and it seems all good from the coils to the plugs so there must not be spark getting to the coils...the only thing i know before the coils is the regulator(cdi box) , the stator, and a relay perhaps? i don't know if i blew something out with the new brakelight i wired or most likely being an idiot and using the "start engine" mode on a car battery charger to get more power to try and get my bike started which i have done in years past but i was told that it's way too many amps for my bike and i probably blew something from that. Does ANYone know what would have gone first? or how to test the stator or regulator to see which is bad? i'd like to buy the parts and fix it myself. i figure i could buy and install both parts for the same price as taking it somewhere to diagnose it and put in one. anyone? any ideas? suggestions? I WANNA RIDE!! HELP! : /
 
1 - 5 of 5 Posts
Top