Ducati Monster Motorcycle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
Several of the rubber boots on my AMP connectors are perished and I'd like to replace them. Is there a way to remove the wires from these connectors. So far I haven't been able to get the terminals out of the connectors, and so far haven't damaged anything whilst trying, but I'm gettin' very near to the damage phase - will I have to cut and resolder the wires ????

WTSDS
 

·
Registered
Joined
·
4,897 Posts
there's a couple of small release tabs on each wire end/connector, you have to take a really small jeweler's flat head screwdriver or a pick to release them.

you have to go in from the front side of the connector (opposite from where the wires go in) and depending on which one you're talking about, you may need to remove the red plate before you can get access to the release tabs...
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #3 ·
Thanks hiero, that's exactly what I need to know, now I can get busy with the leetle teenie weenie tools rather than the snippers.

As nearly all my boots are perished I'm wondering if PO/s have used nasty degreasers or Armour All type stuff to clean the 'bike, or do these just rot away with time. 6 years ain't that old for electrical equipment.

WTSDS
 

·
Registered
Joined
·
4,897 Posts
WTSDS said:
Thanks hiero, that's exactly what I need to know, now I can get busy with the leetle teenie weenie tools rather than the snippers.

As nearly all my boots are perished I'm wondering if PO/s have used nasty degreasers or Armour All type stuff to clean the 'bike, or do these just rot away with time. 6 years ain't that old for electrical equipment.

WTSDS
mine aren't degraded at all actually, the amp connectors are really good stuff...
 
1 - 4 of 4 Posts
Top