Ducati Monster Motorcycle Forum banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
2,060 Posts
Discussion Starter #1
Hey all, I finally got around to installing the HID light system I got from www.gohid.com Here's a picture of the exact system for you kind folks -



As far as the wiring goes, you guys were right, it was pretty easy. But I'm having a lot of trouble finding a place to mount the ballast. The ignitor isn't integrated into the ballast but I found that if you're patient you can fit it into the stock headlight bucket, but the ballast itself is pretty thick (about an inch) and it won't fit between the airbox and ignition like where most folks with monsters put it. The wiring isn't long enough for me to put it under the seat either.
I tried putting it behind the fairing but again it's too thick. I tried mounting it on the frame too, but again, too thick. Can anyone suggest a location? Or can somebody with the same system clue me into where you put yours? As always, mucho mucho thanks!!

Goldenchild -
 

·
Registered
Joined
·
1,720 Posts
w/o seeing exactly what you're working with I'd suggest making a small bracket out of aluminum and mounting it to the triple, or for a quick fix putting it under your airbox lid.
 

·
Premium Member
Joined
·
2,060 Posts
Discussion Starter #3
Justin Sain said:
w/o seeing exactly what you're working with I'd suggest making a small bracket out of aluminum and mounting it to the triple, or for a quick fix putting it under your airbox lid.
Haha! I thought of that, I even went so far as to snaking the wiring through the airbox's intake and if I attached it to the airbox lid on the inside it would've worked but I didn't do that for 2 reasons. For one, I didn't want to retrict the air flow with the wiring (I'd get rid of the lid but I'm running a bit lean), and secondly, I'm not sure how hot the ballast gets and I didn't want to risk starting a fire with the paper air filter!!

I also tried mounting it on the triple but without it sticking way out in the open and making the bike UGLY, there's nowhere to put it :'( I was almost desperate enough to mount it under the lower triple but didn't want to risk the front tire bottoming on it. Thanks for the suggestions though, appreciate it!
 

·
Registered
Joined
·
4,309 Posts
How thick is it? Do you still have the pad that goes over the air box? If so, take that pad out and put the ballast on top of the box.

I don't think the tire will hit it below the triple. That's where I was going to suggest, as that's where a friend of mine mounted the ballast on his BMW GS.
 

·
Premium Member
Joined
·
2,060 Posts
Discussion Starter #5
Yep, I removed the pad a long time ago but the ballast still didn't fit. It's about 30mm thick. As far as below the triple, I'll give it another go, but aren't forks on GS's linkage type forks? Although I'm too sure if that would make a difference. Thanks.
 

·
Premium Member
Joined
·
2,326 Posts
I'm waiting for my HID kit to come, (german mail is sooooo slow). Our plan is to make some brackets and mount it on top of my airbox which is semi-open. I know you said your bike is running lean, so I don't know what to tell you. Is there anyway you can lengthen the wires and attach under the seat area? How about making some brackets and attaching outside but under or/in front of the airbox? or near your horn? i dunno... sorry

what if you get rid of the stock filter and get an aftermarket one and make a cut out the same size as the balast and secured it on/in the airbox lid? Then you would'nt really be restricting anymore flow...




[attachment deleted by admin]
 

·
Premium Member
Joined
·
2,060 Posts
Discussion Starter #7
Thanks Michelle, i'm sorta thinking along those lines...maybe I'll drill holes in the airbox just big enough for the wiring to run through and secure the ballast inside of the lid.

I have to do something cause when I did a test run to see if I got the wiring right, the light output was AMAZING!! I have to have it!!
 

·
Registered
Joined
·
8,800 Posts
What year and model of Monster are you putting it on?

That may help us with suggestions.
 

·
Premium Member
Joined
·
2,060 Posts
Discussion Starter #9
Speeddog said:
What year and model of Monster are you putting it on?

That may help us with suggestions.
Oh sorry, it an '07 695.
 

·
Registered
Joined
·
4,309 Posts
goldenchild said:
Yep, I removed the pad a long time ago but the ballast still didn't fit. It's about 30mm thick. As far as below the triple, I'll give it another go, but aren't forks on GS's linkage type forks? Although I'm too sure if that would make a difference. Thanks.
I don't know how much travel your forks have, but you could look it up,
then cut a piece of wood to that length, stick it on top of your fender and see if the ballast clears it,
this would also give you a margin of error because the static sag is already taken out.

Another idea would be to get the valve cover off a oil-cooler bike and mount it where the oil cooler would mount. You'd probably want to fab or have fabbed a guard, like expanded steel mesh or something.
 

·
Premium Member
Joined
·
2,060 Posts
Discussion Starter #11
^^^Intersting... I'm going to have to look at that, thanks!!
 

·
Registered
Joined
·
8,800 Posts
On my S4, the fender will come to within 3/4" of the bottom of the triple at full bump:



Perhaps you can find someplace underneath the airbox?
 

·
Registered
Joined
·
270 Posts
My kit has a separate igniter and ballast also and I was able to put both of them side by side in the space in front of the airbox...no drilling needed as it fits snug enough to not move.

Sorry no pics to post right now, but I can if requested.
 
1 - 13 of 13 Posts
Top