Ducati Monster Motorcycle Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
My gas light indicator started wigging out on me since the last time I got it back from the shop (damn SS!!!) basically full tank or not, it will periodically switch on and off. I am now completely ignoring it. I know I can reset the trip meter every time a fill up and use that as a judge, but frankly would like to get my gas light working again.

Anybody know if this is easy enough for me to do on my own. I don't want to take it back to South Seas as the last time I handed it over to them they kept it for a month and didn't do anything to it but aparently break the gas light indicator. I only got it back from them because my Girlfriend called them up and begged for it back for my birthday since her main present to me was some new Remus Slip-ons. #$*@@!!!! Anyway I am getting off the subject...

If there are a few things that I could look at to see if there is a loose connection or something that may fix it, then I would like to start there.

On a related note: I ran out of gas yesterday for the first time and was wondering two things:
1) My manual talks about a reserve tank (don't remember how big) but does not talk about how to switch to it. Is there one? is there a way to switch to it?
2) how big is the gas tank on an '03 M800 supposed to be? once I got it to a gas station I was only able to get 3 gallons into it before it looked to be full. I thought it was more like a 5 or 6 maybe even 8 gallon tank. Could I be seeing the wrong thing? There is this plate that you see when you open the tank, I basically watch that while I am filling the tank up and when the gas gets to looking like it is above the level of that plate I stop filling it, is this correct? Could I be filling it too fast, and it needs time to drain down into the main section of the tank? Could I be only filling the reserve?

Thanks,
Jonathan
 
G

·
Jonathan,

Your tank should hold somewhere around 4 gallons. And yes, you are filling it correctly.

I don't believe that there is a seperate 'reserve tank' for the fuel. On my 2001 S4 there is a sensor that triggers the low fuel light when the tank is 3/4 empty. However, I'm not familiar with the new M800, as an S4 and an old M900 have been the limits of my Ducati experience.

Just curious, did the dealer do any repairs to the speedo-tacho assembly? If you cross the wrong wires in there you can end up frying your reserve light. . . . I did :-/

Also, if you are contemplating buying a new sensor, the price is somewhere around $148.00. Before you do that, check your connections!
 

·
Registered
Joined
·
45,105 Posts
there is no reserve. reserve is when the light comes on. you already know not to trust that light. the problem is eithe the sending unit or the ground wire from the sending unit. if the dealer has a unit in stock, i big nut, i connector, job done under warranty.
 

·
Registered
Joined
·
96 Posts
check the connection. On my '00 750 when i took my talk off last winter i accidentally loosened the wires without knowing it. I was acting all f'd up and i later found that was the culprit.
I rewired it and it works fine.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #5 ·
I am going to see if I can find a loose wire somewhere in there. I am really hoping it is not a fried sensor even though it would be covered under warranty, I really don't want to take it back to those guys as, they had it for a month the last time, for a similar problem that they didn't even fix, and aparently caused this problems in the process.

If anyone has some close up pics of where the wires are that I should be fucusing on I would appreciate it.

Thanks,
Jonathan

p.s. still doesn't really explain how I only got 3 gallons into 4 gallon tank though??? wierd.
 

·
Registered
Joined
·
1,305 Posts
lets check it out on Saturday if you don't find it sooner
 

·
Registered
Joined
·
3,363 Posts
Hey, Hawaii, I am having the same trouble with the fuel light on my '03 620. Basically the light will come on and flicker. It will even respond to throttle input. Throttle on...light comes on. Throttle off...lights goes off. Blip throttle...light blips. Does your's act like that or does it just come on?

Folks here have told me to check my connections and the relay for the sensor. My starter button is also acting up. How is your starter working?
 

·
Premium Member
Joined
·
1,200 Posts
My gas light indicator started wigging out on me since the last time I got it back from the shop (damn SS!!!)
 
1 - 8 of 8 Posts
Top