Ducati Monster Motorcycle Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
03 Monster 620 Heres a brief history- bike sat for months and is not ridden very often, at first had trouble starting and wouldnt turn over so I passive jumped with my car and fired her up but it would only stay on when the fast idle was turned up, rode her around the block and there was hardly any power when throttled, trickle charged the battery and was able to start the bike without jumping. Didnt start the next day so I trickle charge again. Now she is completely dead, nothing turns on when the key is turned except the headlight when turned all the way to the left. Tried passive jumping with the car and still nothing....the parking light is the same brightness when jumper cables are hooked up. Could it still be the battery even if the bike doesnt turn on when hooked up to the car battery? Im hoping this is an easy fix so I can avoid the hassle of towing it to the dealer and then having to pay out the ass. thanks in advance
 

·
Registered
Joined
·
635 Posts
03 Monster 620 Heres a brief history- bike sat for months and is not ridden very often, at first had trouble starting and wouldnt turn over so I passive jumped with my car and fired her up but it would only stay on when the fast idle was turned up, rode her around the block and there was hardly any power when throttled, trickle charged the battery and was able to start the bike without jumping. Didnt start the next day so I trickle charge again. Now she is completely dead, nothing turns on when the key is turned except the headlight when turned all the way to the left. Tried passive jumping with the car and still nothing....the parking light is the same brightness when jumper cables are hooked up. Could it still be the battery even if the bike doesnt turn on when hooked up to the car battery? Im hoping this is an easy fix so I can avoid the hassle of towing it to the dealer and then having to pay out the ass. thanks in advance
my friend, you NEED a new battery.... it happened to me...
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
my friend, you NEED a new battery.... it happened to me...
Thanks for your reply but if it was a matter of electrical power, wouldnt the bike turn on when i have the jumper cables connected from the car battery? The immobilizer light doesnt even come on.
 

·
Premium Member
Joined
·
67 Posts
I am not sure it makes any difference - but I would try to jump start it direct - without your bike battery in the circuit - someone else might know if that makes a difference
 

·
Premium Member
Joined
·
165 Posts
Thanks for your reply but if it was a matter of electrical power, wouldnt the bike turn on when i have the jumper cables connected from the car battery? The immobilizer light doesnt even come on.
I hope you didn't jumpstart your bike with the car's motor running. A car's battery has more amperage(thanks Mr. Google)and it's charging system is much more powerful than that of a bike. You may risk frying your charging/electrical system. A car's battery is sufficient enough to jumpstart it...without the car engine running.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #6
am i right to think that its something other than the battery because the gauges and immobilizer light dont even come on when the car battery is connected with jumper cables?
 

·
Registered
Joined
·
203 Posts
am i right to think that its something other than the battery because the gauges and immobilizer light dont even come on when the car battery is connected with jumper cables?
The only thing I can offer is to tell you that I have had a battery so dead, that jumping it had no effect. If it is that shot, then the jump may not work. I would get a replacement battery and try that. If that does not work, then you can get it to the dealer as you stated.

I think you are trying to avoid bringing it in and paying for " just a battery". With a bike sitting for long periods with no charger on it, the battery needs to replaced anyway. Is it the original battery? If so you far exceeded the normal life of it
 

·
Registered
Joined
·
635 Posts
am i right to think that its something other than the battery because the gauges and immobilizer light dont even come on when the car battery is connected with jumper cables?

OK, have you checked the fuses? But, do get a new battery, from what you've said, the one you have might have given up its ghost...

Remember, if you connected the car battery while the engine was running, you might have, maybe, maybe, fried the ECU[hope not]
 

·
Registered
Joined
·
52 Posts
Discussion Starter #9
thanks for the input guys. I was passive jumping it without the car on so I hope that prevented me from frying anything. I will try jumping it without the old battery and if that doesnt work Ill try replacing the battery. Thanks again.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #10
I put in a brand new battery and nothing. Fuses are all ok, immobilizer light blinks and the parking light comes on but the gauges dont come on and no fuel pump sound either. Any suggestions before I have to figure out a way to get it to the dealer?
 

·
Registered
Joined
·
635 Posts
I put in a brand new battery and nothing. Fuses are all ok, immobilizer light blinks and the parking light comes on but the gauges dont come on and no fuel pump sound either. Any suggestions before I have to figure out a way to get it to the dealer?
check the relays and the plug connections...
 

·
Registered
Joined
·
52 Posts
Discussion Starter #12
Sorry, my mechanic knowledge is very basic. Can you tell me where on the bike and how to check the relays?
 

·
Registered
Joined
·
635 Posts
Sorry, my mechanic knowledge is very basic. Can you tell me where on the bike and how to check the relays?
lift the tank, on the right side of the bike you'll see the fuse box; besides the battery you should see a little black box, that's a relay, the fuel pump relay it should do a 'click' when you turn the ign switch on...if no 'click' heard, this might be the culprit...but, anyways if you have a multimeter[voltmeter], check for 12V when yu turn the ig switch on if no 12V then, since you stated your mechanical knowledge is limited, then take it to the shop.

if you need further assistance, pm me...
 

·
Registered
Joined
·
14 Posts
LED turn signals

Can someone help me with what I need to do to hook up a set of LED turn signals to my 1997 M750? Thanks.

bob
 

·
Registered
Joined
·
14 Posts
Thanks Carlos. Do I just wire the relay in between the LED signals and my stock wiring? And how many will I need? I'm guess four? Two front and two back? thanks again.

bob
 

·
Registered
Joined
·
635 Posts
Thanks Carlos. Do I just wire the relay in between the LED signals and my stock wiring? And how many will I need? I'm guess four? Two front and two back? thanks again.

bob
you got me there, on my bike, i only use 2 resistors...but, i think there's a thread in this forum about doing this upgrade...try to find it, if not pm, i'll do some research on the subject...

or visit http://www.clearalternatives.com/flasher.htm they have instructions...
 
1 - 18 of 18 Posts
Top