Ducati Monster Motorcycle Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
hey everyone, my first post here. i crashed my 2003 ducati m620 last month while in the malibu canyons on some twisties and thank god i'm doing well..(only a fractured elbow and tons of road rash). the bike was impounded and received the next day. I'm having troubles starting it. i've read other posts on checking the fuses, kickstand up, battery is reading 14amps but when i turn the key i hear the fuel pump prime but when i press the ignition switch nothing happens. i've tried to bypass and go straight to the starter and jump start it and it turns over with good compression but theres no spark.. i've read horror stories about the immobilizer and if so, i bought the bike without a red key nor a key code card. the front speedometer cluster is also toast. any ideas? please help!! -daniel

pictures - http://i863.photobucket.com/albums/ab194/dferrer88/IMG00019-20090726-1937.jpg

http://i863.photobucket.com/albums/ab194/dferrer88/IMG00014-20090726-1934.jpg

http://i863.photobucket.com/albums/ab194/dferrer88/IMG00018-20090726-1935.jpg
 

·
Registered
Joined
·
335 Posts
I know that this may sound very basic, but have you checked the "Kill Switch?" What you are saying about hearing the fuel pump run and the starter not engaging sounds exactly what happens if you try to start the bike and the "Kill Switch" is on. The Kill Switch or its wiring could have been damaged in the crash. Glad you are doing well.
 

·
Premium Member
Joined
·
312 Posts
there is a wreck safety switch on the ecu. unplug the battery for 30 secs and try it again.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
i checked the killswitch and i have power in it, but theres no power in the push button to start the bike. -daniel
 

·
Registered
Joined
·
168 Posts
not sure what you mean by the speedo being toast, but the immobilizer is in the gauge cluster. if you seriously damaged it, that may be your problem. did you try disconnecting the ecu for a couple of minutes?
 

·
Registered
Joined
·
28 Posts
This sounds like my experience, but TG I didn't crash my baby. Sorry to read that, but TG you're doing well. After looking at your pics I'm impressed (and somewhat baffled) you're trying to get it running and possibly get back on there so quick.

http://www.ducatimonster.org/forums/tech/193187-03-monster-620-won-t-start.html#post2305216

I was just up Latigo a few weeks ago pushing harder than I ever have and had a few OS moments. What was it that got you?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #8
i low sided on a left corner.. lots of rocks and sand in the canyon roads :/ total list of injuries were broken toe, sprained left ankle, sprained right elbow, broken pinkie, road rash on shoulder, hand, and left ankle. im young so i feel 100% now, and i was in the process of modding the 620 (termis exhaust, paint...ect)
 

·
Registered
Joined
·
28 Posts
I didn't have to get new Keys because I got the aftermarket ECU and I had the Red Key for syncing the Ignition and headset, etc.

The ECU alone was $1500-1700, I was able to get a whole Termi Kit with ECU, Filter & Hi-pipes for $1750. If you have to get a whole Ignition kit, I think you're in for MUCH more than the bike is worth.

If you want to spend $5000k on fixing up that bike, I'll sell you my '03 620 dark with only 8000k miles, ECU, K&N filter, low Termi's + stock pipes too, frame SLIDERS, bar-end mirrors, handle-bar riser, hidden license plate holder PLUS a warranty through Feb. 2010, all regular maintenance and always garaged for $5500.
 

·
Registered
Joined
·
1 Posts
hello to all, old post, hope I have some luck....I just crashed my 2005 Monster 620 dark....the lights/choke control got destroyed (choke line is dangling), headlight got destroyed as well...the main problem is that the bike won't start.
when I turn the key, the fuel pump starts, but the instrument cluster doesn't do the startup sequence.
the only light on is the immobilizer flash.

I've already tried disconnecting the battery and ECU cables, nothing happens....HELP PLEASE!
 
1 - 11 of 11 Posts
Top