Ducati Monster Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
OK another bone head post... I noticed that my clutch fluid looked like mud...
so I bled the clutch and replaced the fluid (DOT 4) nice and clean .... this lasted about 6-8 weeks it looks like mud again... I will Bleed it out again... Is this common with the Brembo hydrolic Clutch master? or Hydrolic clutches in general? or is there something wrong with my clutch hydrolics ... thanks in advance for your input.
 

·
Registered
Joined
·
335 Posts
You didn't mention what model of bike it was or how old the bike was, but if brake or clutch fluid gets dirty VERY quickly the seals could be going on the master or slave cyl. Be sure that you use DOT 4 or DOT 5.1. DO NOT use DOT 5, as that is silicone based brake fluid and will not work well at all. I have usually used Castorl GT LMA brake fluid, but that's just my choice. If this is a very new bike I might be worried, but if older (3 years up), I don't think I would worry too much. When the seal really go you will know.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Thanks

The bike is an 01 M900Sie.... thought that might be the case ... I assume there are rebuild kits... I will see if I can order new seals... and yes I am using DOT 4.... thanks again
 

·
Premium Member
Joined
·
6,957 Posts
its a seal in your clutch slave that does this.
very common...nothing to worry about.
change the fluid if you want, or replace the slave with an aftermarket part and it will stop discoloring
jeff h
monsterparts.com
01 M900Sie
95 900SS/SP
 
1 - 4 of 4 Posts
Top