Ducati Monster Motorcycle Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Just picked up my new 1100 s from the dealer today and during my 4 hour ride home te check engine light came on. The bike had 2600 miles on it from the previous owner and right at 2700 miles the check engine light came on the bike had been serviced before I took it over. I had just put gas in it 10 miles before the light came on and I put premium fuel in it mabey that gas had been in the ground to long. I pulled over and checked every thing out looked good and it ran fine. Restarted the bike and the light came back on. Got home and went back out on it and no light. What causes the engine light to come on? Is it just coming on to remind of service?
 

·
Registered
Joined
·
880 Posts
Just picked up my new 1100 s from the dealer today and during my 4 hour ride home te check engine light came on. The bike had 2600 miles on it from the previous owner and right at 2700 miles the check engine light came on the bike had been serviced before I took it over. I had just put gas in it 10 miles before the light came on and I put premium fuel in it mabey that gas had been in the ground to long. I pulled over and checked every thing out looked good and it ran fine. Restarted the bike and the light came back on. Got home and went back out on it and no light. What causes the engine light to come on? Is it just coming on to remind of service?
My 1100 EVO has a service light that is separate from the check engine light.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
Read the manual

I read the manual. It has a list of faults that cause the light to come on. I tried to go back and look at the "error" page and it no longer has a fault. But if it happens agin I know how to get to that page and see which error is causing the fault.

Have any of you had an check engine light come on then go off after restarting the bike?
 

·
Registered
Joined
·
1 Posts
I just bought the bike too... (2 days ago), could this happen if I ran out of fuel? the low fuel light is on... but the check engine light too... so I turn off the bike, and the check engine light is no more on...

ideas?
 

·
Registered
Joined
·
29 Posts
My check engine light comes on frequently, when i ride in the mountains, twist the throttle when i start the bike, etc. I took it to the shop and when they checked it the light was no longer on and the dealer could not tell me what was wrong. Unsure where the "error page" is so try to narrow down the problem. Would love to hear how others have corrected their check engine light problem. Thanks!!!
 

·
Registered
Joined
·
76 Posts
Mine on S2R would come on now and then. Bike ran fine and it always shut itself off. Sometimes in a few minutes, sometimes an hour later, etc.
 

·
Registered
Joined
·
296 Posts
Funny someone mentioned overfilling the tank...it just happened to me!! After topping up the gas tank, about 10 minutes in, the CEL came on. No change in ride, everything felt and sounded normal, I got where I was going, shut down. On leaving about 20 minutes later, no more CEL and rode another 98 miles with no CEL. The last time I had CEL, I didn't pay attention if had just filled up or not, but I was last riding season, so almost a year ago, again it cleared itself after I pulled over and shut down!! Hmmmm
 

·
Registered
Joined
·
12 Posts
I know this thread is old but wanted to contribute. After doing a bunch of work on my monster 1100 Evo I went out to ride. No check engine light, until... stopped at the gas station and filled up. I accidentally overfilled a little bit (up into the filler neck) After about 8-10 miles of riding the CEL started coming on intermittently for the next 10 miles home. I googled, then found this thread. Interesting. Not saying overfill is my issue, but is it coincidence??
 

·
Registered
Joined
·
880 Posts
Do you guys have the charcoal canister installed on the bike still? Wondering if excess gas is getting in there and giving the computer funny readings.
 

·
Registered
Joined
·
778 Posts
As far as I've read, seen, and experienced the overflow isn't monitored. It just reburns any overflow or fumes. Too much raw fuel in the canister will cause it to run poorly until it clears, but I've never seen any sensor's in a canister or near it.
 

·
Registered
Joined
·
778 Posts
Well, there goes my theory...
 

·
Registered
Joined
·
582 Posts
+1 on the servo. The error from my CEL indicated the servo and I could not work out why. Servo made noise and all appeared ok. But after wiping then dabbing a bit of grease on the servo cable. I never had the prob again.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
432 Posts
Overfill

I thought all the error codes that occur stay in the CPU Memory for future access by the dealership? Caféracer Mike any substance to this theory?
 

·
Registered
Joined
·
63 Posts
I'm going to revive this thread. I have issues with CEL. My CEL only comes on when I start moving, then it goes off when I stop. Sometimes it doesn't come on for a few miles but then it comes on. When it's on my blinkers won't work either. I stop and everything works fine.
I have a 07 S4R with about 15k miles. I have taken it to the Ducshop and no codes are present. could it be a short somewhere?
 

·
Registered
Joined
·
4 Posts
Mine has been off and on the last few days... would go off and stay off after warming up. I mentioned to the dealer I had been putting around the neighborhood with the wifey. She recently got a new bike, anyways, the owner mentioned it may be the battery not fully charging with the putting around and especially after just starting it up. He also said I should get a battery tender on it. Mines a '14 1200s with a little over 4k miles.
 
1 - 20 of 28 Posts
Top