Ducati Monster Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey, a fairly new (1700 miles) Monster owner here. So I bought a handlebar riser set from Slingshot Racing and installed it with more or less no problems - but instead of being mounted roughly flat, my handlebars were now angled down forward (like, it only raised the rear). So I went to try and adjust things so that they could be mounted flatter, and in the process, loosened the bolt that holds the rigid line coming out of the clutch fluid box which leads to the clutch line (don't know what it's called) so that I could adjust that rigid line out of the way. I tightened it back firmly, and I spilled some fluid so I topped it off to the top of the viewing window. However, the clutch now won't engage. I tried my best to even adjust things back to the way they were, but no dice. I'm not sure on how things work here - saw another thread that was talking about adjusting the clutch engagement zone, that involved melting out some plastic crap covering the adjustment screw (which I definitely saw on my bike). Would doing that and adjusting that help, or have I messed something else up? Any help would be greatly appriciated!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
thanks for the quick reply. found some how-tos on bleeding elsewhere on here, now I've gotta decide if I think I can do that without breaking things worse. hmmm...
 

·
Registered
Joined
·
663 Posts
run out to sears, buy a vacum pump, READ THE INSTRUCTIONS or you wont get a good seal, and go for it. really, a monkey could do it.
 
1 - 5 of 5 Posts
Top