Ducati Monster Motorcycle Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
need some help here as ive exhausted most of my options...

i installed the competition werkes tail chop yesterday on my 696 in the stock position (w/signals) and just before placing everything back together.. i decided to check the lights and signals. the signals are working fine but.. whats happening is that the brake light is now always ON.. as if im always pressing the brakes.. ive checked all the connectors and all the wires twice and problems persists.

any help would be appreciated, since driving at night coule be very dangerous!
 

·
Registered
Joined
·
99 Posts
I helped Samology install the tail chop:

It turned out to be the brake light switch behind the front brake lever

it has some slack/play in it an doesn't butt up against the lever enough.. so it thinks ur braking slightly all the time..

turns out it wasn't related to the tail chop at all.. we just never noticed it before..
 

·
Registered
Joined
·
1 Posts
Hi I have a similar question relating to this thread. I recently purchased a 09 Monster 696. It has a Evotech tail tidey and I noticed that when the bike is parked the brake light is always on. I took apart the rear to verify the wiring was correct and it was.

Here's the kicker. Once I start moving the brake light works correctly. When I look behind me while I am moving I can see that only the rear light is on and when I tap either the front or rear brake the lights are working correctly.

What it seems to me is that when the bike is parked or stopped the brake light is ALWAYS on. Is this a safety feature? I feel like it might be some kind of after market modification feature so that when the bike is stopped the brake light is lit up even if I am not touching the levers. Has anyone ever heard of this or know what my issue might be?

Thank you.
 
1 - 8 of 8 Posts
Top