Ducati Monster Motorcycle Forum banner
21 - 26 of 26 Posts

· Registered
Joined
·
50 Posts
Thanks Adrian. It’s pretty common for these threads to be left open-ended and it’s nice to see closure on this one. I had a similar issue myself on my Buell where the main earth connection from the (rubber mounted) engine to the frame was broken and made intermittent contact. Took a while to find, minutes to fix and the result - big smiles again
Motor vehicle Reflex camera Camera lens Automotive design Camera accessory
 

· Registered
Joined
·
230 Posts
To circle back on my issue of my mystery start issue that had stumped myself and two Ducati techs ...
The symptoms were randomly not starting as a general statement. I would have some luck starting it when the starter wouldn't engage by putting it in gear and rocking the bike. The techs replaces the solenoid and starter after checking a few other things. The solenoid was actually replaced twice thinking the new one was a lemon.

The actual issue was a corroded ground on the frame. SMH
The one from the starter?
 

· Registered
Joined
·
50 Posts
There is no ground connection on the starter motor; it gets grounded through the body itself, that in turn connects to the engine which connects to the frame (to complete the circuit) through that braided strap in my last picture. I hope that makes sense?
 

· Registered
2009 Ducati Monster 1100 S
Joined
·
72 Posts
If you still have a starting problem I can help, first, let me know, second, i must ask if I can share the remedy publicly. Apoarently Ducati has not shared, I paid money to resolve the issue...and I dont want to breach a trust.

let me know
 
21 - 26 of 26 Posts
Top