Ducati Monster Motorcycle Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Hey everyone,

I just got a used 2001 M900sie and I was riding two up for only the second time and the thing started tripping the f out. It would bog down and chug at low rpms then hit really hard then back off again and it died a few times on low speed corners. Super unsafe and scary. Once i got it home and let it rest for a sec i took it one up and it rode perfect again. It had some remus low mounts that were destroyed when i got it and i just have stock pipes now. Could that be it? Check plugs, fuel filter also right? I just hope its not the nightmare the s2r 1000 guys seem to be having. Any suggestions? Its Fi also...
 

·
Banned
Joined
·
897 Posts
I'd definately check the plugs. If you went from Remus to stock pipes you could be runing way rich and fouling.
 

·
Premium Member
Joined
·
1,941 Posts
Usually once the plugs are fouled they tend to run crappy all the time. They won't go from bad to good over a few minutes rest and a restart. Also this will not be the same deal as the new S2R1000s. They have O2 sensors and a whole different injection map version than you do. If it's an on again, off again problem it likely is electrical. I'd check battery voltage. Check the ignition wiring for tight fit and make sure no connector is corroded. Check and clean all grounds. Then check the fuel system.
 

·
Registered
Joined
·
8,324 Posts
The early injected bikes had a computer for fuel management and the same ignition as the carbys. Not sure when they went to the new system. Look near your battery and see if you have 2 black boxes. Those could be intermittent and the source of your problem. Check your plugs to see if one is darker than the other and then swap the boxes. If the dark plug swaps cylinders, there's your problem. BTW, the wiring/connectors on those boxes is very fragile. Be gentle. Also those things are expensive. Look for used ones if you need them.
 

·
Registered
Joined
·
760 Posts
Start with the basics first.

Where in the RPM range was this problem? What RPM is a "low speed corner"?

You just got this bike. Are you completely familiar with the history/service of this bike? Is it properly tuned? Valves, TB's & CO? does it have a stock air filter/box top? I know you mentioned it's got Remus pipes, but what else, does it have a PowerCommander?

Have it checked/tuned by a mechanic you trust. Once you've ruled that out (or fixed the issue) then look at the actual ECU (it's a 1.5 which I've got an extra stock one that you could borrow to test after you've got it tuned)

But narrow it down first.

Please post with your progress.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #6 ·
Thanks for all the suggestions. I bought it from the local dealer and it was his personal bike so service should have been kept up on it. I've got my buddy/tech looking at it today to see what he can find out. It had remus pipes but Im 90% sure no power commander.

Low speed turns for me are between 1000-3000rpms
The chugging was between 3000-5000 but it would also make a popping noise sometimes.

I just rode it to my buddies house and it was OK but not as good as before, it made a real thumping feeling right under the fuel tank...more than usual ;)

I'll let you know what we find out.
 

·
Premium Member
Joined
·
56 Posts
2001Cromo has covered must of the problems you could be facing and I would like to add that you check for pinched fuel lines under the gas tank and fuel filter, fuel pump problems in the gas tank.

Also FYI for Ducpainter, I have a 00 M900Sie and the ignition is handled by the 1.5 ECU and not by the ignition boxes like my 95 SS was. :)
 
1 - 8 of 8 Posts
Top