Ducati Monster Motorcycle Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi all,

I have a 2000 M900S. The tach is acting all crazy on me; it does not read properly. It will either stick / hover around 1k - 2k or bounce around all psycho-like when I'm at freeway speeds.

The photo likely shows the culprit (the screws).



Is there a way to remove JUST the tach from the gauge cluster to sort this out? Tricky?

Which leads to me to this: anyone have a digital version of a factory service manual for a 2000 M900? I searched for it, but it's just a disaster when trying sort through all the screwed up links and no-replys when it comes to service manuals. I suppose I can't expect much more now, but thought it'd be worth a shot.

Thanks a ton for your insight and help, everyone. Be safe and have fun.

- Ryan
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
Did you fix your tach ?

I'm having the same problem.
Hey, gjscott.

I haven't gotten around to fixing it, but have discovered some very useful info.

It's super easy to remove the entire tach assembly from the gauge cluster. The trick for us now is finding an exact replacement or an aftermarket tach that fits and looks alright in the stock cluster and next to the stock speedo.

I'll start my hunt in the near future and share anything I find. Likewise, if you go looking for a replacement tach and find anything cool, please share; I'd like to see what you come up with and I'm sure there are others that may be interested as well.

Thanks for bumping this and reminding me that I should stop ignoring the problem and just fix it already.

Have an awesome New Year.

- Ryan
 

·
Premium Member
Joined
·
47 Posts
Do a forum search for'900ie tach replacement'. Thread will tell you how to fix the problem. I was told by a dealer that there is no replacement for the stock tach, and at the time I was looking, factory replacement was about $400.
Bill
 
1 - 7 of 7 Posts
Top