Ducati Monster Motorcycle Forum banner

1 - 2 of 2 Posts

·
Registered
07 Ducati Monster 695 Dark
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello People,
I had purchased a 695 dark about 2 months ago. Friggin love it... I am the third owner of this bike with complete maintenance records, ( which seem to be right in line with the suggested maintenance intervals) manual, etc handed over when I purchased it. It has 12,500miles on it. (11,300 at the time of purchase)I have gone through the bike as best as I can. (new plugs/magnecore wires, new gpr exhaust, techron fuel system treatment, new front springs that are better for my weight, new slave cylinder for the clutch, Oil change... blah blah blah.

I had recently noticed surging and backfiring between 2,500-4,500 rpms with the throttle steady. It almost seems like a rhythmic surging. So, thats when i put the fuel treatment in the tank. Ran it through, noticed a difference in how she runs. However, I was still getting the intermittent issue. Had my local ducati tech install a rapidbike tuner, because he said it would alleviate the issue. It made a HUGE difference in how the bike ran! For about 200 miles... Now I am experiencing the same thing. the only thing that I have not addressed is the fuel delivery system. I have seen in the records that the monster specific issue of the dumb red fuel pump wire had been fixed a while back. I am wondering if anyone else is experiencing this issue! With the rapidbike tuner installed, and the computer now "learning" how I ride, and constantly making adjustments. I am now wondering what steps I need to take to make sure it's healthy!


Any and all advice i can get would be GREATLY appreciated!
Thanks
 

·
Registered
Joined
·
29 Posts
Does the 695 have O2 sensors? For shits and giggles, try unplugging them and see what happens. Your will get a light/code, but will run fine.
 
1 - 2 of 2 Posts
Top