Ducati Monster Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello all, I have a 02 s4 monster and it is missing the instrument cluster. I got it this way, and I cannot get it to start. I have the red key and the two black keys, and the code card. Now my question is this, I need to get a cluster of course, but I have been told three different things. One that you have to have a new cluster the old ecu will not work with a used cluster from another bike(without the ecu and ignition and keys), two that you can get a used cluster and with the red key you can "program" the new-used cluster, three that you have to send the used cluster, ecu, and ignition and keys off to someone who can program it-I have been told everywhere from 350.00-500.00. Any definitive answer on this problem? Thanks in advance
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
OK, I think I have it figured out with research. Could not get anybody to respond here or pm me. I think that I have to have the immobilizer disabled in the ecu and that will do it...Anybody know for sure or have recommendations as who can do it for a reasonable price? I PM'ed monstermash about it, but no response. Thanks for any help-or not..
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thank you, I got my used cluster today and could not get the bike to run with even doing the code on the immobilizer with the throttle...need to have the ecu "cleansed"...
 
1 - 4 of 4 Posts
Top