Ducati Monster Forums: Ducati Monster Motorcycle Forum

Ducati Monster Forums: Ducati Monster Motorcycle Forum (https://www.ducatimonster.org/forums/)
-   Tech (https://www.ducatimonster.org/forums/tech/)
-   -   Immobilizer flash sequence, what do they mean? (https://www.ducatimonster.org/forums/tech/312121-immobilizer-flash-sequence-what-do-they-mean.html)

sadtaco 11-13-2015 02:32 AM

Immobilizer flash sequence, what do they mean?
 
Here's a short video of my S2R I took tonight; when I turn the key, everything spins up, fuel pump primes, and the bike will start. The only catch is the immobilizer light flashes and stays on, at least until the bike starts. Anyone know what this means?

The wiring is fine, the only thing I noticed is that there is a wire harness that is not connected to anything, near where the TPS sits, and next to the kickstand sensor connector. I removed the kickstand wire and connected a loopback adapter TPO sells to eliminate the wire, but everything else is connected.

https://youtu.be/dkxjF4Tk5gc

Mobilespider 11-13-2015 01:27 PM

I came across this on the site link below. I posted it on my thread a couple of days ago, maybe this applies to your bike year as well:

In my poking around the iNet for info I came across this info (http://www.avantiraceparts.co.uk/page.php?id=29) on the flashes from the Immobilizer Light. Not sure if it applies to all years but seems to match mine.

The flash sequences occur just after the key is turned on and the dash completes it power on dance:

if the system is OK, the Immobilizer LED stays off;

the LED flashes once to indicate that the serial connection is missing (this is the direct connection - through the main wiring - between engine control unit and immobiliser control unit in the instrument panel);
the LED flashes twice to indicate that the key in the switch, or the immobiliser antenna, or both, are faulty;
the LED flashes three times to indicate that the system does not recognize the key you have inserted;
the LED flashes four times to indicate that the engine control unit has been programmed, but the immobiliser is blank.

After the fault flashes finish, the LED comes on and stays on if engine ignition is inhibited.

Mine Flashes twice then it stays on, I have no starter operation and suspect no ignition either.

sadtaco 11-13-2015 01:37 PM

Thanks for sending that over. It looks to me liked it flashed 3x and then stayed on, what do you think?

Mobilespider 11-13-2015 02:03 PM

Ok, watched your video a couple of times now.

looks to me that you have 1 flash
I see it come on after the dash dance, goes out for a period, flashes once, goes out for a period then stays on.

On mine the flashes are 2 quick ones. I should video mine to see how it looks.
Mine does everything you indicate on yours when I turn the key but mine does not start, nothing happens when the button is pressed. If the Immobilizer is kicking in then you lose starter and ignition but EFI system still primes.

sadtaco 11-13-2015 02:09 PM

OK. I'll double check and see if I can locate that serial connection.

shefreak 06-08-2016 06:46 PM

can you give me an update on you immobilizer problem? My bike is doing the same. flashes twice, then stays lit. I have no key code to reset the immobilizer to recognize my key. I'm happy to learn, from you 'Avanti' link that it may be the key ignition or antenna being faulty.

can you shed some light on my situation?

Anne

ride4lame 06-25-2016 10:53 AM

Mine flashes once, then steady.

Is there a connector that is likely disconnected? If so where?

If I unplug the smaller connector attached to the key switch then it flashes twice...

Mister Ducati 06-25-2016 12:06 PM

Quote:

Originally Posted by ride4lame (Post 3040514)
Mine flashes once, then steady.

Is there a connector that is likely disconnected? If so where?

If I unplug the smaller connector attached to the key switch then it flashes twice...

This indicates that there is a bad connection between the ECU and the immobiliser control unit in the instrument panel.

Mister Ducati 06-25-2016 12:09 PM

Quote:

Originally Posted by shefreak (Post 3034634)
can you give me an update on you immobilizer problem? My bike is doing the same. flashes twice, then stays lit. I have no key code to reset the immobilizer to recognize my key. I'm happy to learn, from you 'Avanti' link that it may be the key ignition or antenna being faulty.

can you shed some light on my situation?

Anne

The LED flashes twice to indicate that the key in the switch, or the immobiliser antenna, or both, are faulty
Does this happen with both of the black transponder keys or just one.

ride4lame 06-26-2016 09:06 AM

Quote:

Originally Posted by Mister Ducati (Post 3040546)
This indicates that there is a bad connection between the ECU and the immobiliser control unit in the instrument panel.

I figured out my issue.
I had a ground improperly placed. The ground near the ecu was going to the battery instead of an actual ground. woops.
immobilizer seems good now.
No flashes.

Still need to figure out why the starter isn't getting signal.

Thanks yall!


All times are GMT -5. The time now is 03:34 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome