Ducati Monster Forums: Ducati Monster Motorcycle Forum - Reply to Topic
Thread: At what RPM does your 1100 Evo idle? Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ducati Monster Forums: Ducati Monster Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-05-2019 03:35 PM
Kirigakure
Quote:
Originally Posted by fastfinch View Post
Just like the title says. I bought a 2013 1100 Evo a month ago and to me, it seems like it isn't idling as it should be. It fires up ok but when I ride and I come to a stop it idles about 2100 RPM for about 8 seconds then drops to about 1200RPM. Sometimes it doesn't drop and stays idling at 2100RPM. Is this normal for the bike or is something wrong? Thanks in advance for your input.
This happens to my 2013 EVO from time to time as well. I usually just let the clutch out just enough for it to idle back down to normal rpm and it's good to go. I can't replicate it, but it does happen from time to time.
04-27-2019 01:52 PM
fastfinch
At what RPM does your 1100 Evo idle?

Just like the title says. I bought a 2013 1100 Evo a month ago and to me, it seems like it isn't idling as it should be. It fires up ok but when I ride and I come to a stop it idles about 2100 RPM for about 8 seconds then drops to about 1200RPM. Sometimes it doesn't drop and stays idling at 2100RPM. Is this normal for the bike or is something wrong? Thanks in advance for your input.

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome