Hydraulic Clutch Problem - Ducati Monster Forums: Ducati Monster Motorcycle Forum
 
Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-23-2019, 03:27 PM Thread Starter
Junior Member
 
Soldier's Avatar
 
Join Date: Aug 2019
Posts: 4
Hydraulic Clutch Problem

Recently doing maintenance on a newly acquired 07 695.my clutch fluid was murky .
I performed a fluid change and was “ bleeding “ the little Be to get a good lever.
Before could , I completely lost all pressure.
I have completely removed and cleaned
The master, slave, all connections etc.
Still nothing? I have tried to use a mighty vac but seem to get almost endless air?
I have checked for leaks without success.
Any thoughts would be appreciated
Thanks
Soldier is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-31-2019, 02:43 PM
Junior Member
 
kwakman's Avatar
 
Join Date: May 2017
Posts: 15
Garage
So if I understand, you lost all pressure to the hydraulic clutch circuit while bleeding the system? Or was this before you bled the system?

If it was before, check the master cylinder, there is a small rubber boot at the end of the piston that can split. Someone on another group I'm in had this happen to him, it was on the clutch side as well so possibly the same thing. I would have posted pictures but I can't retrace which group it was in.

I you lost pressure after trying to bleed the system, maybe try a pressure bleeder instead of a vacuum. Like this.


Good luck.

----------------

Eastcoast Ducati Hoodlum.
Ride: 2014 M1200S
kwakman is offline  
post #3 of 5 (permalink) Old 08-31-2019, 04:17 PM Thread Starter
Junior Member
 
Soldier's Avatar
 
Join Date: Aug 2019
Posts: 4
Thanks , my saga continues. I have replaced the clutch master 2 X ( with used ones) bled it at least 7 times ( I even bled it backwards from the slave) I have tried multiple versions of combinations of the parts. Is cap rubber boot etc...
This began “ while bleeding “ the clutch master following fluid change. I had pressure, but then lost everything in attempts to get it better!
I was unable to locate a new clutch master,
I have a new slave on order, but can’t shake the feeling that it’s the master.( no pressure) also no leaks anywhere?
Any advice is welcome, I need to ride!
Any advice on parts would be appreciated.
Thanks
Soldier is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 09-05-2019, 02:58 AM
Senior Member
 
Join Date: Mar 2009
Posts: 186
your slave cylinder is shot... when you install the new one it should be good to go
Toker Indy Rules is offline  
post #5 of 5 (permalink) Old 09-05-2019, 08:24 AM Thread Starter
Junior Member
 
Soldier's Avatar
 
Join Date: Aug 2019
Posts: 4
Thanks, I had ordered one a week ago, still waiting. I was reluctant because I thought I would have had pressure at the master?
Does the slave just “ suck “ air when it’s bad? Thanks
Soldier is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ducati Monster Forums: Ducati Monster Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome