TPS Reset - Ducati Monster Forums: Ducati Monster Motorcycle Forum
 
Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-01-2012, 03:33 PM Thread Starter
HB3
Member
 
Join Date: May 2008
Posts: 45
TPS Reset

After having the ECU re-flashed on my 06 S4R (996 motor) the bike is surging a little at constant low RPM’s and it is backfiring/popping on decell. The bike never did this on the stock map even with the full Zard system: it runs great when out on the road and in the twistys. I have had the TPS reset and the fuel trim done. The dealer who did the re-flash said that I had to set the TPS manually to get rid of the issues. I have searched high and low on setting the TPS manually and I have found that it can be done and that it cannot be done. Is setting the TPS manually possible or should I return the ECU and have the dealer put a stock map back on the ECU?
HB3 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-01-2012, 08:00 PM
Senior Member
 
nextfriday's Avatar
 
Join Date: May 2011
Posts: 202
I've read on the sport classic forum that guys have reset the tps manually by cycling their ignition on/off 5 times in a row and then starting the bike. I am skeptical of this, but it's worth a try in your case. I'd leave the kill switch off till the last cycle or you'll prime the motor with too much fuel too.


Sent from my Motorcycle iPad app
nextfriday is offline  
post #3 of 5 (permalink) Old 05-04-2012, 07:54 AM Thread Starter
HB3
Member
 
Join Date: May 2008
Posts: 45
That sounded too good to be true. Tried it and there was no change in how the bike ran. Thanks for the idea.
HB3 is offline  
post #4 of 5 (permalink) Old 05-04-2012, 11:07 AM
Senior Member
 
TheDucPilot's Avatar
 
Join Date: Jan 2011
Location: Saskatoon, Saskatchewan, Canada
Posts: 162
You need to go to a dealer or have the software to get into the ECU to reset the TPS. I use the TechnoResearch Centurion S software.
TheDucPilot is offline  
post #5 of 5 (permalink) Old 05-04-2012, 01:23 PM Thread Starter
HB3
Member
 
Join Date: May 2008
Posts: 45
I have had all the work done at my local dealer and I am still have small issues. I will be up an running with the ducatidiag software next week, we will see if I can make sing just like it use to!!
HB3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ducati Monster Forums: Ducati Monster Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome